67-73 Cougar Sequential Turn Signal Trouble Shooting Thread

If it's mechanical, electrical or just downright confusing, this is the place to find and share answers.
Bluestuff
Registered Member
Posts: 322
Joined: 04 Nov 2018, 01:11
Location: NewZealand

Re: 67-73 Cougar Sequential Turn Signal Trouble Shooting Thread

#381

Post by Bluestuff »

My recommendation would be to stop chasing your tail, and buy a complete LED set up from wccc and install it all.

The improvements are out standing better and you will know every thing is working !
MikaelVroom
Registered Member
Posts: 6
Joined: 05 May 2016, 10:04

Re: 67-73 Cougar Sequential Turn Signal Trouble Shooting Thread

#382

Post by MikaelVroom »

cougarsunlimited.net wrote: 18 May 2020, 14:57 First, the front bulbs should be 1157A not 1156. Correct this first!
Oops, I replaced the backup lights at the same time and got my numbers mixed up. The fronts are correct!
Also, a 552 flashes too fast and may not allow enough time for the 2nd and 3rd bulbs to turn on.

However, since only the inner most bulb on each side is turning on in brake light mode, it points to a bad sequential controller/connector.
What’s the recommended flasher? The WCCC site referenced the 552 flasher so that’s what I went with.
User avatar
cougarsunlimited.net
Registered Member
Posts: 137
Joined: 26 Apr 2013, 18:13
Location: Albuquerque, NM
Contact:

Re: 67-73 Cougar Sequential Turn Signal Trouble Shooting Thread

#383

Post by cougarsunlimited.net »

Use a D0WY-13350-AR for both the turn signal and emergency flasher.
It has a longer (~1.2 second) cycle time instead of .3 to .4 second cycle time of a 552 flasher.
Attyhyde
New Member
Posts: 2
Joined: 18 May 2020, 18:21

Re: 67-73 Cougar Sequential Turn Signal Trouble Shooting Thread

#384

Post by Attyhyde »

I have a ‘68 and have installed the LED upgrade kit and the solid state sequential unit from WCCC. Everything works fine except the far right passenger side light when the right blinker is on. The bulb lights up when the light switch is pulled so I’m sure the bulb is fine. Is this most likely the connection at the socket or is the wiring the more likely culprit?
User avatar
cougarsunlimited.net
Registered Member
Posts: 137
Joined: 26 Apr 2013, 18:13
Location: Albuquerque, NM
Contact:

Re: 67-73 Cougar Sequential Turn Signal Trouble Shooting Thread

#385

Post by cougarsunlimited.net »

Attyhyde wrote: 18 May 2020, 18:33 Everything works fine except the far right passenger side light when the right blinker is on. The bulb lights up when the light switch is pulled
Try swapping the bulb with one of the other bulbs to determine if the bulb or socket is the problem.
MikaelVroom
Registered Member
Posts: 6
Joined: 05 May 2016, 10:04

Re: 67-73 Cougar Sequential Turn Signal Trouble Shooting Thread

#386

Post by MikaelVroom »

Tinkered with it a bit more, suddenly the left center joined the party as well? But inconsistently. I started wiggling wires to see if anything was loose, and in the process wiggled the sequential box. Stuff started pouring out of the box, so I popped it open to find...

Image

Image

Image

I don't know, can anybody spot anything wrong? :lol:

Time for an upgrade.
User avatar
cougarsunlimited.net
Registered Member
Posts: 137
Joined: 26 Apr 2013, 18:13
Location: Albuquerque, NM
Contact:

Re: 67-73 Cougar Sequential Turn Signal Trouble Shooting Thread

#387

Post by cougarsunlimited.net »

MikaelVroom wrote: 20 May 2020, 05:53 Tinkered with it a bit more, suddenly the left center joined the party as well? But inconsistently. I started wiggling wires to see if anything was loose,

...
Time for an upgrade.
You can reuse the black plastic case - after cleaning.
Hopefully, the red and black connectors can be separated and are not corroded.
If they are, replacements are available.
MikaelVroom
Registered Member
Posts: 6
Joined: 05 May 2016, 10:04

Re: 67-73 Cougar Sequential Turn Signal Trouble Shooting Thread

#388

Post by MikaelVroom »

I cranked and yanked and pried on those connectors quite a bit and couldn't get them to budge. I have some Weather Pack connectors lying around from another project I may use instead.
User avatar
cougarsunlimited.net
Registered Member
Posts: 137
Joined: 26 Apr 2013, 18:13
Location: Albuquerque, NM
Contact:

Re: 67-73 Cougar Sequential Turn Signal Trouble Shooting Thread

#389

Post by cougarsunlimited.net »

MikaelVroom wrote: 20 May 2020, 10:10 I cranked and yanked and pried on those connectors quite a bit and couldn't get them to budge. I have some Weather Pack connectors lying around from another project I may use instead.
Unfortunately, Weather Pack connectors won't match the original connectors as used on the original or upgraded sequential controller.
I had these pigtails made up to solve this problem:
C9WY-13H366-AR pigtails.jpg
C9WY-13H366-AR pigtails.jpg (128.08 KiB) Viewed 468 times
User avatar
bmwhd1
Registered Member
Posts: 475
Joined: 13 Oct 2015, 14:33
Contact:

Re: 67-73 Cougar Sequential Turn Signal Trouble Shooting Thread

#390

Post by bmwhd1 »

MikaelVroom wrote: 20 May 2020, 05:53 Tinkered with it a bit more, suddenly the left center joined the party as well? But inconsistently. I started wiggling wires to see if anything was loose, and in the process wiggled the sequential box. Stuff started pouring out of the box, so I popped it open to find...

I don't know, can anybody spot anything wrong? :lol:

Time for an upgrade.
Holy F! It's a miracle any bulb anywhere did anything.
Todd

'70 Conv, 351C-4V, T5z
Lone Star Cougar Club
Post Reply

Return to “Classic Cougar Maintenance Restoration and Repair”