Blinkers don’t work

Do you have questions about the CCOA? Want to know how to join? Need information about shows and schedules? This is the place to go.
Post Reply
Kelleyw85
Registered Member
Posts: 3
Joined: 08 Nov 2021, 12:46

Blinkers don’t work

#1

Post by Kelleyw85 »

I have a 67 cougar and I did the blinker upgrade. My hazard lights work but the blinkers do not. What could the problem be?
User avatar
coachJack
Registered Member
Posts: 294
Joined: 30 Aug 2013, 17:14
Location: SF Bay Area

Re: Blinkers don’t work

#2

Post by coachJack »

What is this "Blinker Mod" you are talking about?

Do your dash indicators and the front turn signal lights work when putting the turn signal switch in left and right?

Coach Jack
Kelleyw85
Registered Member
Posts: 3
Joined: 08 Nov 2021, 12:46

Re: Blinkers don’t work

#3

Post by Kelleyw85 »

What did is replace the modals in the trunk with the kit from WCCC. I have not done the led bulbs yet. The front turn signals work it’s just the back ones that do not work.
User avatar
coachJack
Registered Member
Posts: 294
Joined: 30 Aug 2013, 17:14
Location: SF Bay Area

Re: Blinkers don’t work

#4

Post by coachJack »

Kelley,

You should start with downloading my pdf file

https://classiccougarcommunity.com/arti ... _Guide.pdf

What parts did you swap out? What exactly was the problem before and after you swapped the components? Your problem could simply be the fuse for the turn signal switch ( used for the turn signals ) is blown or it could be a more complicated issue, without detailed information, its just a wild guess.

Coach Jack
sfhess
Registered Member
Posts: 722
Joined: 01 Nov 2011, 13:38

Re: Blinkers don’t work

#5

Post by sfhess »

Kelleyw85 wrote: 08 Nov 2021, 14:12 What did is replace the modals in the trunk with the kit from WCCC. I have not done the led bulbs yet. The front turn signals work it’s just the back ones that do not work.
Probably because the module for LEDS cannot handle the load of the incandescent bulbs.
Kelleyw85
Registered Member
Posts: 3
Joined: 08 Nov 2021, 12:46

Re: Blinkers don’t work

#6

Post by Kelleyw85 »

Coach Jack

What I put on is item 24078 from WCCC. The reason I had to do it was the mechanical component in the trunk was broke into. The gears in it were missing. Ever sense I put the new parts in the blinkers have not worked. They worked before the mechanical part broke. I am wondering if the relay that you leave hooked up the one with the blue wire is bad. What do you call it and what is it for?

Kelley
Post Reply

Return to “The CCOA public discussion area”