67 Headlights dont function

If it's mechanical, electrical or just downright confusing, this is the place to find and share answers.
User avatar
Midlife
Registered Member
Posts: 948
Joined: 25 Mar 2014, 16:36
Location: Tucson, AZ
Contact:

Re: 67 Headlights dont function

#11

Post by Midlife »

Ummm...green/black are high beams, red/black are low beams.
Let me check your shorts!
http://midlifeharness.com
User avatar
Chuck
Registered Member
Posts: 152
Joined: 06 Feb 2016, 10:59
Location: Sunny Phoenix, AZ
Contact:

Re: 67 Headlights dont function

#12

Post by Chuck »

Midlife wrote: 07 Nov 2021, 22:06 Ummm...green/black are high beams, red/black are low beams.
Ooops, got the colors backards in my description.
=============================================
1956 Ford Thunderbird - Fiesta Red and White top
1967 Ford Mustang GTA Coupe - Wimbledon White and Black vinyl top
1970 Mercury Cougar Eliminator - Competition Yellow, 428 CJ, 4-speed
1986 Ford Mustang SVO - Medium Canyon Red
User avatar
Chuck
Registered Member
Posts: 152
Joined: 06 Feb 2016, 10:59
Location: Sunny Phoenix, AZ
Contact:

Re: 67 Headlights dont function

#13

Post by Chuck »

OK, I have voltage to the dimmer switch and jumping power to Green/Blk puts on the high beams but jumping power to Red/Blk does nothing. I have followed the wires up from the dimmer switch but the disappear behind a vent. They must come back under the dash somewhere (in order for the high beam indicator to function) and there may be a connector here where I need to check for continuity before the wires go forward into the firewall connection. Is this assumption correct, so far, and where is this connector located exactly?

Thanks in advance,
Chuck
=============================================
1956 Ford Thunderbird - Fiesta Red and White top
1967 Ford Mustang GTA Coupe - Wimbledon White and Black vinyl top
1970 Mercury Cougar Eliminator - Competition Yellow, 428 CJ, 4-speed
1986 Ford Mustang SVO - Medium Canyon Red
User avatar
Chuck
Registered Member
Posts: 152
Joined: 06 Feb 2016, 10:59
Location: Sunny Phoenix, AZ
Contact:

Re: 67 Headlights dont function

#14

Post by Chuck »

Wait, I may have an answer. I jumped the low beam relay and heard it click but no lights. Don't tell me I've just got a simple bad crimp from relay to headlights? More tofollow...
=============================================
1956 Ford Thunderbird - Fiesta Red and White top
1967 Ford Mustang GTA Coupe - Wimbledon White and Black vinyl top
1970 Mercury Cougar Eliminator - Competition Yellow, 428 CJ, 4-speed
1986 Ford Mustang SVO - Medium Canyon Red
User avatar
Chuck
Registered Member
Posts: 152
Joined: 06 Feb 2016, 10:59
Location: Sunny Phoenix, AZ
Contact:

Re: 67 Headlights dont function

#15

Post by Chuck »

Found it...<duh!> Need to make sure that both relays are wired alike. Now working (no more wiring after dark for me). Sheesh!
=============================================
1956 Ford Thunderbird - Fiesta Red and White top
1967 Ford Mustang GTA Coupe - Wimbledon White and Black vinyl top
1970 Mercury Cougar Eliminator - Competition Yellow, 428 CJ, 4-speed
1986 Ford Mustang SVO - Medium Canyon Red
Post Reply

Return to “Classic Cougar Maintenance Restoration and Repair”