Search found 416 matches

by berns68
14 Sep 2018, 11:33
Forum: '67 '68 Parts for Sale
Topic: 67 cougar hood Need one
Replies: 4
Views: 223

Re: 67 cougar hood Need one

I came across this gentleman when I was looking for a rear end housing that he had on Craigslist in the Rockford Il area. He mentioned to me he had a 67 hood also. I had him send me the pics so I could post them here and let anyone interested contact him directly. I have no involvement other than th...
by berns68
12 Sep 2018, 21:09
Forum: Classic Cougar Maintenance Restoration and Repair
Topic: Repair or replace?
Replies: 12
Views: 338

Re: Repair or replace?

There was no way I was going to reinstall the third member after almost 51 years of grime so I cleaned and painted it too. Looks great and I hope it makes it another 50 years.
IMG_4394.PNG
IMG_4394.PNG (684.67 KiB) Viewed 58 times
IMG_4394.PNG[/attachment]
by berns68
12 Sep 2018, 20:59
Forum: Classic Cougar Maintenance Restoration and Repair
Topic: Repair or replace?
Replies: 12
Views: 338

Re: Repair or replace?

I hope to have the additional parts to finish installing this weekend. Here is a pic of the housing how it looked when I purchased it and now after wire wheeled, sanded, primed, and painted.[attachment=1]IMG_4395.JPG[/attachment
by berns68
12 Sep 2018, 20:38
Forum: Classic Cougar Maintenance Restoration and Repair
Topic: Repair or replace?
Replies: 12
Views: 338

Re: Repair or replace?

CATHOUSE wrote:
12 Sep 2018, 18:46
Make sure that the replacement housing has the Cougar wedge locating holes in the spring plates. It may not if it came out of a Mustang.

Randy Goodling
CCOA #95
It has the correct perches on it.
by berns68
12 Sep 2018, 20:36
Forum: Classic Cougar Maintenance Restoration and Repair
Topic: Repair or replace?
Replies: 12
Views: 338

Re: Repair or replace?

Sometimes you just get lucky. I decided to just replace the housing but finding one I found wasn't easy. I called all the local scrap and salvage yards and no had anything that old anymore. Between Craigslist and eBay I found a decent one in Virginia and ordered it Sunday. However after a day and a...
by berns68
12 Sep 2018, 07:25
Forum: Classic Cougar Maintenance Restoration and Repair
Topic: Repair or replace?
Replies: 12
Views: 338

Re: Repair or replace?

Sometimes you just get lucky. I decided to just replace the housing but finding one I found wasn't easy. I called all the local scrap and salvage yards and no one had anything that old anymore. Between Craigslist and eBay I found a decent one in Virginia and ordered it Sunday. However after a day an...
by berns68
11 Sep 2018, 08:22
Forum: '67 '68 Parts for Sale
Topic: 67 cougar hood Need one
Replies: 4
Views: 223

Re: 67 cougar hood Need one

I may have a source for one in the Rockford, Il area if interested.
by berns68
08 Sep 2018, 09:15
Forum: Classic Cougar Maintenance Restoration and Repair
Topic: Repair or replace?
Replies: 12
Views: 338

Repair or replace?

After returning from a cruise night this past Tuesday, Wednesday morning I discover a pool of differential fluid on the garage floor. The split in the factory weld is almost 2/3rds completely around the circumference of the axle tube to the pumpkin. Has anyone ever experienced this and what have the...
by berns68
29 Aug 2018, 21:07
Forum: Classic Cougar Maintenance Restoration and Repair
Topic: Rear axle retaining bolts
Replies: 17
Views: 339

Re: Rear axle retaining bolts

Follow up - After 12 days and over 400 miles later, today I removed the tire and brake drum and applied my torque wrench and the four nuts had not loosened up at all. Also no noticeably diff fluid leaking anywhere. So I'm confident that it was my failure to properly seat the first axle seal that was...
by berns68
17 Aug 2018, 08:07
Forum: Classic Cougar Maintenance Restoration and Repair
Topic: Rear axle retaining bolts
Replies: 17
Views: 339

Re: Rear axle retaining bolts

Mike, In the picture where you show the two seals, new and used one, the used one sure looks like the bearing retainer had been rubbing, if this is what it looks like, then either the seal was not seated in the tube or the bearing and retainer is not on far enough. I am just trying help you get it ...