Holley 600 secondary’s not opening

If it's mechanical, electrical or just downright confusing, this is the place to find and share answers.
superbond
Registered Member
Posts: 217
Joined: 17 Feb 2017, 06:03
Location: Ontario, Canada

Re: Holley 600 secondary’s not opening

#11

Post by superbond » 11 Jun 2018, 13:16

Advanced it a few degrees like you said. Runs good. Hard on gas guess that’s to be expected. Thank all you guys for the advice

superbond
Registered Member
Posts: 217
Joined: 17 Feb 2017, 06:03
Location: Ontario, Canada

Re: Holley 600 secondary’s not opening

#12

Post by superbond » 13 Jun 2018, 15:22

So
After driving for a few days with no issues well maybe one. I smell gas quit often. Strong smell. There are no leaks and it’s seems to be only while accelerating on the hwy. is there anything I should check? How do I check to see if the machanical fuel pump is pumping too much fuel. It’s relatively new

superbond
Registered Member
Posts: 217
Joined: 17 Feb 2017, 06:03
Location: Ontario, Canada

Re: Holley 600 secondary’s not opening

#13

Post by superbond » 20 Jul 2018, 10:13

I advanced the timing. It’s at 14-15 degrees. Runs good. But isn’t that to high for timing. I read no more then 12 degrees. I’m still having overheat issues if I sit at long red lights temp climes fast. Start driving and come down fast.

User avatar
cj750
Registered Member
Posts: 516
Joined: 26 Nov 2011, 19:42
Location: Siloam Springs, Arkansas

Re: Holley 600 secondary’s not opening

#14

Post by cj750 » 20 Jul 2018, 12:11

A larger accelerator pump squirter will often help with hesitation/stumble.
Every post I make comes with a request for corrections. I'm here to learn.

1969 Cougar Eliminator 351 4V, yellow
1970 Cougar Eliminator 428SCJ, black

User avatar
cj750
Registered Member
Posts: 516
Joined: 26 Nov 2011, 19:42
Location: Siloam Springs, Arkansas

Re: Holley 600 secondary’s not opening

#15

Post by cj750 » 20 Jul 2018, 12:19

Is the gas smell coming from underhood or from the exhaust? Absent a visible leak/flooding, I can't think of any good reason for a strong underhood gas smell.
Every post I make comes with a request for corrections. I'm here to learn.

1969 Cougar Eliminator 351 4V, yellow
1970 Cougar Eliminator 428SCJ, black

User avatar
Royce
Registered Member
Posts: 1265
Joined: 22 Oct 2011, 07:14
Location: Dallas, TX

Re: Holley 600 secondary’s not opening

#16

Post by Royce » 20 Jul 2018, 14:10

1. Missing hood to cowl seal
2. Hood not adjusted properly so there is a gap between the hood and the hood to cowl seal


superbond wrote:
13 Jun 2018, 15:22
So
After driving for a few days with no issues well maybe one. I smell gas quit often. Strong smell. There are no leaks and it’s seems to be only while accelerating on the hwy. is there anything I should check? How do I check to see if the machanical fuel pump is pumping too much fuel. It’s relatively new
1968 GT-E XR-7 W code 427 Augusta Green / Saddle
1968 XR-7 R code 428CJ Ram Air Red / Black
1910 Model T Ford Touring Red / Black
1914 Model T Touring Maroon / Black
1915 Model T Ford Touring Black / Black
1917 Model T Ford Torpedo Runabout Green / Black
XR7-G Registrar

Post Reply